スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
--------(--)
 

yahooBBのモデムが不安定になってしまった。

2011.1/4

 今日急にyahooBBのモデムが不安定になってしまいました。昨日までなんともなかったのですが,まさかの事態です。とりあえずサポートにメールを送りましたからきっとなんとかなると信じています。


それにしてもモデムが不安定になるときついですね。puttyでssh接続しているときに急にセッションが切れてしまいました。まだviで保存してなかったのにorz


今までと部屋の環境は変わっていないのでモデムが故障したんだと思いますが,外部の変化だと困りものですね。最近うちのアパートが光に対応したみたいなので,その影響もあったりするんでしょうか?早くモデムを交換してほしいものです。


ところでsakura Internet の VPSにopenpne3.4・wordpress3.0.4をインストールしてみました。


OpenPNE3」は無料で使えるSNSです。インストールも簡単な方だと思いますし,日本語で無料なSNSはこれくらいしかないんじゃないかな。ちなみにPHP(symfony)で作ってあります。

wordpress」は無料で使えるブログですね。インストールもすごい簡単です。Moval Typeは高いのでwordpressしか使えないわけです。こっちもPHPですね。


両方ともPHP・MySQLを使うのでVPSで構築するならインストールしとかないといけないですね。自分がインストールしたものを下に書いときます。


CentOS 5 (x86_64) ・・・デフォルトです。
PHP 5.2.13                 ・・・デフォルトはPHP 5.1.6なので入れ直しました。
MySQL 5.1.54             ・・・デフォルトはMySQL 5.0.77なので入れ直しました。
phpMyAdmin 3.3.9    ・・・PHP5.2以降・MySQL5.1以降はたしかphpMyAdmin3x系が使えるので。
(デフォルトのPHPとMySQLではphpMyAdminは2x系しか使えないと思います)

なんかphpMyAdminで「お使いの PHP MySQL ライブラリのバージョン 5.0.67 が MySQL サーバのバージョン 5.1.54 と異なります。これは予期しない不具合を起こす可能性があります。」っていう警告?注意みたいなのが出ますが,イマイチ直し方がわかりません。誰かわかる方がいましたら教えてください。今のところ特に不具合も無いので放置してます。


OpenPNE3.4を入れたのですが,PHPが5.2以上5.3未満が推奨だったので5.3まではあげないようにしました。5.3まで上げるのなら「Les RPM de Remi」のRPMリポジトリで簡単に済みます。方法は「RX-7乗りの適当な日々さん」がわかりやすく載せてくださっています☆使ってないのでわかりませんがopenPNE3.4でもPHP5.3でいいのかもしれません。


phpMyAdminはデータベース管理が簡単になるので入れました。ブラウザで簡単にデータベースを編集できるので便利ですね。近々インストール方法でも載せてみようと思います。特にopenPNE3x系はインストール方法やカスタマイズ方法が載ってるサイトが少ないですからね。


sakura Internet とか他のレンタルサーバーでもVPSにするならSSHクライアントは無いと困りますね。sakura VPSはリモートコンソール画面があってブラウザでSSHが使えるのですが,javascriptかなんかで表示しているらしくてコピーはできるのですがペーストができませんでした。だからネットで探したコマンドをペーストできずに打ち込まなくてはいけません。メンドクサイこと②ということでペーストがしたいならSSHクライアントソフトが必要になると思います。


オススメは「puTTY ごった煮版」です。自分がこれしか使ったことがないのでww 使い方はいろんなページで詳しく説明してくださってます。文字コードだけUTF-8にしとかないと文字化けで読みにくいので注意してください。「ウィンドウ→変換→文字コード変換→文字コードの設定」で「UTF-8」を選べばいいです。UTF-8にも色々種類がありましたがただのUTF-8でいいと思います。


ではでは。

スポンサーサイト
2011-01-04(Tue)
 

コメントの投稿

非公開コメント


MAxUraのプロフィール

MAxUra

名前:MAxUra
年齢:学生です。
趣味:ネットサーフィン
           DVD鑑賞
特徴:さまぁ~ずファンです
          Linux初心者です

Win,Linux,フリーソフト関連のメモを載せる予定です

 現在はWindows7 64bitを使用しています(2010年3月までは自分のPCはvistaなのでフリーソフトは基本vistaで動作済みってことになります)

コメント・相互リンク募集中です。

紹介してほしいソフトなどありましたら気軽にコメントやメールください♪

ブログ内検索フォーム
プログラミング関係
Black Cat Clock
メールフォーム

名前:
メール:
件名:
本文:

おすすめブラウザ
Firefoxをいつも使ってます
Firefox ブラウザ無料ダウンロード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。